ArcGIS Pro 3.0 发布(附安装程序)

ArcGIS Pro 3.0 发布(附安装程序)-地理信息云
ArcGIS Pro 3.0 发布(附安装程序)
此内容为免费资源,请登录后查看
0
免费资源

 ArcGIS Pro 3.0 计划于 2022 年 6 月推出。

ArcGIS Pro 遵循版本和修补程序帮助中所述的语义版本化规范,这意味着当第一个数字发生更改时,它是主要版本。主要版本通常需要进行向后重大更改,这意味着在版本 3.0 中创建或保存的 ArcGIS Pro 文档(.aprx、.mapx 等)无法在早期主要版本(如 2.x)中直接打开。

  • ArcGIS Pro 3.0 是一个重大变更版本。
  • 安装 ArcGIS Pro 3.0 需要 .NET 6 Desktop Runtime x64
  • 如果在浮动版许可上运行 ArcGIS Pro,请确保先更新到 ArcGIS License Manager 2022.0,然后再更新到 ArcGIS Pro 3.0。2022.0 预计将于 2022 年 6 月 7 日推出,可从 My Esri 下载。

1 ArcGIS Pro 3.0 新特性

作为 ArcGIS 2022 Q2 版本的一部分,ArcGIS Pro 使用户能够通过全新的功能、性能和工作效率改进来扩展其 GIS 功能。通过我们的 ArcGIS Pro 3.0 新增功能视频了解 ArcGIS Pro 中的所有新功能,或者请继续阅读以发现此最新更新的几个亮点。在深入探讨要点之前,请务必查看在 ArcGIS Pro 2.x 和 3.0 之间迁移和工作的最佳实践,请随时单击此处的链接获取最新信息。

1.1 从 ArcGIS Pro 2.x 迁移到 3.0

查看新的系统要求并安装 ArcGIS Pro 3.0 后,可以打开您或其他人在 ArcGIS Pro 2.9 或更早版本中创建的工程和文件,因为它们是向前兼容的。使用 ArcGIS Pro 3.0 保存它们时,将使用允许您利用新功能的属性启用它们。

1.2 向后兼容性

由于 ArcGIS Pro 3.0 是主要版本,因此它保存的文件可能适用于也可能不适用于 ArcGIS Pro 2.x 系列。本主题后面提供了哪些有效和哪些无效的详细信息。但是,如果您创建或保存的工程和文档始终在 ArcGIS Pro 3.x 中使用,则无需担心这些详细信息。发生这种情况时,就是这种情况:

  • 您不会与其他 ArcGIS Pro 用户共享 ArcGIS Pro 文件,例如,如果您是组织中唯一的 GIS 分析师。
  • 您和同事(他们之间共享 ArcGIS Pro 文件)同时升级到 ArcGIS Pro 3.0。

考虑到当同事使用同一主要版本时,协作会得到简化,组织可能计划同时将其所有 ArcGIS Pro 2.x 实例迁移到 3.0。

1.3 划重点

现在,您已经掌握了运行最新版本的 ArcGIS Pro,下面是我们非常喜欢的一些功能,我们很高兴为您带来这些功能。

1.3.1 包管理器

包管理器页面可用于管理在 ArcGIS Pro 中使用的 conda 环境。以前标识为 Python 页面的包管理器页面现在支持将您在先前版本的 ArcGIS Pro 中创建的 conda 环境升级到当前版本、修复损坏的环境以及重命名现有环境。

此外,包管理器的响应速度更快,具有新的任务队列来跟踪环境的状态和包更改,并为所有操作提供了详细的 conda 消息。

图片[1]-ArcGIS Pro 3.0 发布(附安装程序)-地理信息云

1.3.2 向报表添加地图

现在可以向报表添加地图。添加到报表页眉或页脚的映射是静态的。您可以激活地图框以调整地图范围或比例。添加到组页眉、组页脚或详细信息子部分的地图是动态的。在报表视图中,无法激活动态地图的地图框。但是,导出的结果会更新比例和范围,以反映该子节中包含的一个或多个要素。

图片[2]-ArcGIS Pro 3.0 发布(附安装程序)-地理信息云

1.3.3 知识

如果已正确配置 ArcGIS Enterprise 11.0 知识服务器,则可以使用 Neo4j 数据库作为 NoSQL 数据存储创建新的调查和知识图谱。

新的地理布局可用于链接图表。链接图表中的实体使用其空间几何定位在地图上。还可以将空间数据添加到链接图中,并且底图可用于为知识图谱的空间实体提供上下文。

有关更多新功能和更新的许可信息,请参阅数据管理和工作流部分中的 ArcGIS 知识

图片[3]-ArcGIS Pro 3.0 发布(附安装程序)-地理信息云

1.3.4 导出预设

您可以在 ArcGIS Pro 中为地图和布局创建导出预设。导出预设会保存特定导出类型的所有设置。导出地图或布局时,可以选择默认预设或您创建的自定义预设。这样可以获得更快、更一致的导出体验。

预设位于功能区“共享”选项卡上的导出库中。您还可以浏览到文件系统上的预设文件 (.xprt)。可以为任何导出类型创建预设。

图片[4]-ArcGIS Pro 3.0 发布(附安装程序)-地理信息云

2 ArcGIS Pro 3.0 系统要求

在虚拟机或物理机上安装或升级 ArcGIS Pro 之前,请确保您的系统满足运行它的最低要求。此外,了解建议使用哪些资源来获得最佳性能。

ArcGIS Pro 3.0 是包含重大更改的主要版本。请参阅第二节从 2.x 迁移到 ArcGIS Pro 3.0,了解这对共享和协作有何影响。

2.1 支持的操作系统

下面列出的 Microsoft Windows 操作系统支持 ArcGIS Pro,因为其提供商目前也支持该操作系统以供一般或公共使用。

操作系统最新更新或服务包测试
Windows 11 家庭版、专业版和企业版(64 位)2022 年 5 月更新
Windows 10 家庭版、专业版和企业版(64 位)2022 年 5 月更新
Windows 8.1 Pro 和 Enterprise(64 位)2022 年 5 月更新
Windows Server 2022 Standard and Datacenter(64 位)2022 年 5 月更新
Windows Server 2019 Standard and Datacenter(64 位)2022 年 5 月更新
Windows Server 2016 Standard and Datacenter(64 位)2022 年 5 月更新
Windows Server 2012 R2 Standard and Datacenter (64 位)2022 年 5 月更新
Windows Server 2012 Standard and Datacenter (64 位)2022 年 5 月更新

注意:

  • 除非另有说明,否则支持这些操作系统版本的早期和将来的更新或 Service Pack。操作系统版本和更新也必须受操作系统提供商的支持。
  • 桌面体验选项在所有版本的 Windows Server 上都是必需的。

2.2 硬件要求

* 如果不满足 DirectX 要求,ArcGIS Pro 将自动使用 OpenGL。如果您怀疑驱动程序存在问题,可以手动更改为 OpenGL。

注意:

  • 请务必使用最新的可用驱动程序。
  • 某些地理处理工具需要支持 AVX 指令集的处理器。
  • 使用 GPU 时,请确保制造商当前支持该 GPU。
  • 云存储服务(如 Microsoft OneDrive 和 Google Drive)不受支持,除非在有关特定工具和功能的文档中另有说明。了解有关 ArcGIS Pro 和云存储服务的详细信息

GPU 上的通用计算 (GPGPU)

运行 ArcGIS Pro 不需要支持使用 CUDA 的 GPGPU,但运行大多数深度学习功能都需要支持。它还可以加速某些空间分析工具

注意:

过期的 GPU 驱动程序将导致深度学习工具失败,并显示运行时错误,指示未安装 CUDA 或存在不受支持的工具链。确认您拥有 NVIDIA 直接提供的最新 GPU 驱动程序。

2.3 软件要求

在安装 ArcGIS Pro 之前,必须安装以下软件:

软件最低要求
微软 .NETMicrosoft .NET Desktop Runtime 6.0.5 - Windows x64

ArcGIS Pro 3.0 提供了三种许可类型。根据您使用的类型,您可能需要其他软件或访问 ArcGIS Online。

  • 指定用户许可 - ArcGIS Pro 通过 ArcGIS Online 或 ArcGIS Enterprise 上的组织帐户获得许可。如果许可是通过 ArcGIS Online(默认选项)获得的,则不需要许可软件,因为 ArcGIS Online 是 Esri 提供的基于云的服务。如果许可是通过 ArcGIS Enterprise 获得的,则必须安装下表中指示的版本之一,以及相应的受支持的 ArcGIS 许可管理器版本。ArcGIS EnterpriseArcGIS 许可管理器11.02022.010.9.12022.010.92022.010.8.12022.010.82022.010.7.12022.010.72022.010.6.12022.010.62022.0
ArcGIS EnterpriseArcGIS 许可管理器
11.02022.0
10.9.12022.0
10.92022.0
10.8.12022.0
10.82022.0
10.7.12022.0
10.72022.0
10.6.12022.0
10.62022.0

2.4 开发工具包要求

SDK GitHub 存储库中介绍了使用 ArcGIS Pro SDK 创建外接程序的最低要求。

2.5 虚拟化

ArcGIS Pro 在各种本地和云环境中受支持,如下表所示。

在所有环境中,建议使用与您的虚拟化平台兼容的 GPU,以获得最佳用户体验。

注意:

帮助的虚拟化部分提供了有关为 ArcGIS Pro 设置虚拟化环境的其他信息。

注意:

  • 强烈建议不要使用带有 Citrix XenApp 的 ArcGIS Pro,因为 Windows 操作系统会话分配和 GPU 内存管理不善。
  • 如果使用应用程序分层将 ArcGIS Pro 添加到 Citrix XenDesktop 或 XenApp,则由于对 Flexnet 许可服务的权限不足,应用程序可能无法启动。要防止失败,请使用参数 MODIFYFLEXDACL=TRUE 运行 Flexnet 许可服务的命令行安装。示例: msiexec /I “C:\Program Files\ArcGIS\Pro\Resources\ArcGIS Licensing Service\ArcGISls.msi” MODIFYFLEXDACL=TRUE
  • ArcGIS Pro 在以下环境中提供名义级别的功能和性能:
    • 微软 App-V
    • VMware App Volumes

3 从 ArcGIS Pro 2.x 迁移至 3.0

在安装 ArcGIS Pro 3.0 后,可以打开您和其他人在 ArcGIS Pro 中创建的工程和文件,因为它们向前兼容。 使用 ArcGIS Pro 3.0 保存它们时,会启用其一些属性,允许您利用新功能。

3.1 向后兼容性

由于 ArcGIS Pro 3.0 是主要版本,其保存的文件可能适用于 ArcGIS Pro 2.x 系列,也可能不适用。 将在本主题的稍后部分中详细介绍哪些适用,哪些不适用。 但是,如果您创建或保存的工程和文档将始终在 ArcGIS Pro 3.x 中使用,则无需关心所有的详细信息。 这适用于以下情况:

  • 您没有与其他 ArcGIS Pro 用户共享 ArcGIS Pro 文件,例如您是组织中的唯一 GIS 分析人员。
  • 您和您的同事共享 ArcGIS Pro 文件并同时升级到 ArcGIS Pro 3.0。

假如同事们采用相同的主要版本时可以简化协作,组织可能计划同时将其所有 ArcGIS Pro 2.x 实例迁移至 3.0。

3.2 重要工作流

ArcGIS Pro 的软件开发组花费大量时间和精力提高质量和消除漏洞。 将以近连续的方式运行数百万次自动化测试并且每天添加新的测试,软件开发人员和自动化分析人员会检查代码,并且将在每个开发周期中执行全面的测试事件。 然而,无法完全消除引入中断工作流的漏洞的风险。

通常,主要版本引入漏洞的风险最高,因为对代码库进行了大量更改。 次要版本的风险较低。 修补程序版本是三个版本中最安全的,因为它用于针对性地修复漏洞。

注:

在语义版本化中,ArcGIS Pro 3.0 视为主要版本。 有关详细信息,请参阅版本和修补程序

作为用户,遇见漏洞可能需要花费时间修复并且会令人沮丧,尤其当重要工作流被中断时。 在这种情况下,可能需要回滚升级。 一些组织会执行以下任一或全部操作来缓解此风险:

  • 在测试环境中安装新软件并在将重要工作流推出至整个组织之前对其进行认证。
  • 仅在后续修补程序或次要版本同时可用后迁移至下一主要版本。

3.3 使用 ArcGIS Pro 2.x 和 3.0

如果与您协作的用户无法同时迁移至 ArcGIS Pro 3.0,您需要了解在 ArcGIS Pro 2.x 和 3.0 之间可以和不可以共享的内容。 下面几节提供了这些详细信息和其他相关信息。

一般建议

  • 如果要与仍在使用 ArcGIS Pro 2.x 的其他组织或团队成员进行协作,创建备份或工程包。
  • 对于共享,仍可以继续从 ArcGIS Pro 3.0 共享到 ArcGIS Enterprise 或 ArcGIS Server 10.9.1 或更早版本,尽管内容可能会降级。 要使用新功能,将 ArcGIS Pro 3.0 与 ArcGIS Enterprise 11 搭配使用。

3.4 工程

  • 使用任何版本的 ArcGIS Pro 2.x 所保存的工程和工程模板(.aprx、.ppkx 和 .aptx 文件)均可通过 ArcGIS Pro 2.x 和 3.0 打开和使用。 但是,使用 ArcGIS Pro 3.0 保存的工程和工程模板无法通过 ArcGIS Pro 2.x 打开。
  • 可以在 3.0 中创建工程包,然后在 2.x 中作为工程打开。
  • 您无法保存通过任何 ArcGIS Pro 2.x 版本都可以打开的 ArcGIS Pro 3.0 工程的副本。 如果使用最近版本的 ArcGIS Pro(例如 2.9)保存工程,则该工程可以使用先前版本的 ArcGIS Pro 2.x(例如 2.0)打开,但该工程会适当降级以适应先前版本。
  • 如果当前工程最初使用 ArcGIS Pro 2.x 创建,则在 3.0 中保存更改之前会出现警告。 如果继续,则工程版本将更改为 3.0,ArcGIS Pro 2.x 将无法打开该工程。 如果将工程共享,考虑使用另存为保存特定于 ArcGIS Pro 2.x的 工程副本。 仍可以打开 1.x 工程。
  • 在 2.x 和 3.0 中,工程文件内的内容结构未发生变化。
  • 沿用了用户配置设置。

3.5 文档

  • 地图、图层、报表和布局文件(.mapx、.lyrx、.rptx 和 .pagx 文件)在 3.0 中创建或保存后无法在 2.x 中打开。
  • 在 3.0 中,地图文档采用 JSON 格式。 在 2.x 及更早版本中,采用 XML 格式进行创建。
  • 在 3.0 中,不支持 Globe 服务图层。 建议将原始图层重新发布到受支持的服务,例如地图服务或要素服务。 对于将 globe 服务用于高程的工程,可以使用默认 Esri 地势图 3D 服务。

3.6 样式

  • 在早期版本中,Web 样式将降级,但是仍可以进行发布。
  • 将仅发布与先前版本兼容的样式。
  • 样式可以升级至 3.0。 在升级过程中,将创建 2.x 样式的备份副本。
  • 2.x 样式仍可以只读打开,仅当升级至 3.0 时才能进行编辑。
  • 只能从目录视图升级只读样式。
  • 对于 2.x,移动样式将为只读,在升级至 3.0 后可编辑。

3.7 布局

  • 从 ArcGIS Pro 3.0 开始,布局中的图片将以不同的方式存储。 在早期版本中,需要工程包才能看见图片。

3.8 打包

  • 用于打包的地理处理工具可创建包,以允许您与使用早期版本的 ArcGIS Pro 其他团队成员进行协作。
  • 使用共享功能区中的命令创建的包(例如图层、地图和工程包)将包含 2.x 和 3.0 内容。

3.9 共享

  • Web 图层和服务将在与目标服务器兼容的内容中共享。 这意味着无需移至 ArcGIS Enterprise 11 即可更新到 ArcGIS Pro 3.0。 共享至 ArcGIS Enterprise 或 ArcGIS Server 10.9.1 或更早版本时,较新的内容可能降级。 共享至 ArcGIS Enterprise 11.0 时,web 图层和服务将包含在 ArcGIS Pro 3.0 中提供的较新内容。
  • 创建包含服务器连接信息的服务定义时,.sd 文件将包含与服务器版本匹配的内容。
  • 创建连接中性离线服务定义文件时,需要指定目标服务器版本(10.9.1 或更早版本、11.0 或更高版本或者 ArcGIS Online)才能确保文件包含与服务器版本兼容的内容。
  • 可以在 ArcGIS Pro 2.x 和 3.0 中打开移动地图包。

3.10 地理数据库

  • 在 3.0 中创建的数据集可能与先前版本不兼容。
  • 有关地理数据库的信息,请参阅客户端和地理数据库兼容性,这将在发布 3.0 时进行更新。
  • 在 3.0 中创建的属性规则与 2.x 不兼容。

数据类型

  • 创建或更新至 3.0 的注记不适用于 2.x。
  • 创建或更新至 3.0 的尺寸标注不适用于 2.x。
  • 在 3.0 中创建的公共设施网络和追踪网络不适用于 2.x。

3.11 地理编码

  • 在 3.0 中,已移除创建地址定位器标准化地址。 需要更新引用创建地址定位器工具的脚本或模型才能使用新工具:创建定位器创建要素定位器。 需要更新引用标准化地址工具的脚本或模型才能使用将在 3.0 中提供的将地址分割为组件工具。 有关详细信息,请参阅创建地址定位器标准化地址的弃用通知。
  • 在 3.0 中,已移除使用创建地址定位器工具创建的定位器,在 3.0 或更高版本中,无法将其添加至 ArcGIS Pro。 可以获取有关定位器的详细信息,以使用创建定位器工具或创建要素定位器工具创建替换定位器。
  • 在升级至 3.0 之前,确定使用创建地址定位器构建的定位器,然后再次进行创建。 要确定定位器是否是使用“创建地址定位器”工具创建的,以及参考数据、字段映射和所用设置,在 ArcGIS Pro 2.9 或更早版本中打开定位器属性,然后单击关于定位器选项卡。 如果样式版本以 10.x 编号列出,则定位器是使用创建地址定位器工具创建的。 如果版本以 2.x 编号列出,则定位器是使用创建定位器工具或创建要素定位器工具创建的。

3.12 数据管理

  • 在 3.0 中,基于地图的 Reviewer 规则已移除并不再可用。 建议您将自动检查工作流迁移到属性规则中的可用 Data Reviewer 功能。 在 3.0 中打开或保存地图文档 (.aprx) 时,将从文档中移除所有现有地图规则。

3.13 地理处理

  • 自定义 ArcGIS 工具箱文件 (.atbx) 默认在 3.0 中创建并与 2.9 兼容。
  • 自定义旧工具箱文件 (.tbx) 在 3.0 中为只读。 现有 .tbx 文件及其工具在 3.0 中为只读,无需任何更改即可继续使用。 要对工具进行任何更改,需要将该工具复制到 .atbx 文件。
  • 可以在 3.0 中打包工具箱以保持与先前 2.x 版本的兼容性。
  • 可通过将 2.x 中的工具和工具箱复制粘贴到 .atbx 文件中对其进行升级。

3.14 Python

  • 在 ArcGIS Pro 3.0 中,Python xlrd 库版本将从 1.2.0 升级至 2.0.1。 2.0.1 版本的 xlrd 不再支持读写 Microsoft Excel .xlsx 文件。 要使用 .xlsx 文件,使用 openpyxl 或 pandas 库。
  • 在 ArcGIS Pro 2.x 中编写的 Arcpy.mp 脚本仍适用于 3.0,但是必须更新 CIM 版本才能访问 3.0 CIM。 有关详细信息,请参阅 Python CIM 访问

3.15 任务

  • 另存为 .esriTasks 文件的任务项目在 3.0 中保存后无法在 ArcGIS Pro 2.x 中打开。
  • ArcGIS Pro 2.x .esriTasks 文件可以在 3.0 中打开并在保存工程后进行升级。
  • 在 3.0 中创建的任务项目不适用于 ArcGIS Pro 2.x。

3.16 加载项


原文链接:

① ArcGIS Pro 3.0 新特性
② 从 ArcGIS Pro 2.x 迁移至 3.0
③ ArcGIS Pro 3.0 系统要求

© 版权声明
THE END
喜欢就支持一下吧
点赞14 分享
评论 共4条

请登录后发表评论